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Seeing is believingSeeing is believing.
– Proverb

Form ever follows function.
– Louis Henri Sullivan

Intelligence …is the faculty of making
artificial objects, especially tools to make tools.

– Henri-Louis Bergson
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OBJECTIVESOBJECTIVES
In this chapter you will learn: 
 The basics of the Visual Studio Integrated The basics of the Visual Studio Integrated 

Development Environment (IDE) that assists 
you in writing running and debugging youryou in writing, running and debugging your 
Visual Basic programs.
 Visual Studio’s help features.Visual Studio s help features.
 Key commands contained in the IDE’s menus 

and toolbars.and toolbars.
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OBJECTIVESOBJECTIVES
 The purpose of the various kinds of windows 

in the Visual Studio 2008 IDEin the Visual Studio 2008 IDE.
 What visual programming is and how it 

simplifies and speeds program development.simplifies and speeds program development.
 To create, compile and execute a simple 

Visual Basic program that displays text andVisual Basic program that displays text and 
an image using the Visual Studio IDE and the 
technique of visual programming.
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2.1 Introduction
2.2 Overview of the Visual Studio 2008 IDE
2.3 Menu Bar and Toolbar
2.4 Navigating the Visual Studio IDE
2.5 Using Helpg p
2.6 Using Visual Programming to Create

a Simple Program that Displays Text
and an Image 
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2.1 Introduction

• Visual Studio 2008 is Microsoft’s Integrated 
Development Environment (IDE) for creating runningDevelopment Environment (IDE) for creating, running 
and debugging programs.

• A simple Visual Basic program can be created by• A simple Visual Basic program can be created by 
dragging and dropping predefined blocks into place 
through visual programming.through visual programming. 

 2009 Pearson Education, Inc.  All rights reserved.



7

2.2 Overview of the Visual Studio 2008 
IDEIDE

• Start Microsoft Visual Basic 2008 Express Edition. (Fig. 2.1)
New Project buttonNew Project button

Start Page tab

 2009 Pearson Education, Inc.  All rights reserved.
Fig. 2.1 | Start Page in Visual Basic 2008 Express Edition. 

Collapsed Toolbox window Start Page links Empty Solution Explorer (no projects open)
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• The Recent Projects section shows solutions 
you have been working onyou have been working on.

• Getting Started focuses on using the IDE for 
creating programs learning Visual Basic connectingcreating programs, learning Visual Basic, connecting 
to the developer community and providing 
development tools.development tools.

• Visual Basic Express Headlines and 
MSDN: Visual Basic Express Edition link p
to information about Visual Basic.
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• The IDE also has an internal web browser.
• To request a web page enter its URL into the location bar (Fig 2 2)• To request a web page, enter its URL into the location bar (Fig. 2.2).

Requested web page (URL in location bar
drop-down menu)

Selected tab for requested web page

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.2 | Displaying a web page in Visual Studio.
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• Select File > New Project... to create a new 
project (Fig 2 3)project (Fig. 2.3).

• Project templates are the project types users can 
create in Visual Basiccreate in Visual Basic.

– A Windows Forms application has a graphical user interface 
(GUI).  ( )
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

Windows Forms Application (selected)

Default project name
(provided by Visual Studio)

Description of selected project
(provided by Visual Studio)

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.3 | New Project dialog. 
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• Click OK to display the IDE in Design view
(Fig 2 4)(Fig. 2.4).  

Active tab Tabs Menu Menu bar Solution Explorer window

Form (Windows Forms application)( pp )

Properties window

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.4 | Design view of the IDE.
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• As you place controls on the Form, you’ll be able to modify 
their propertiestheir properties.

• Figure 2.5 shows where the Form’s title text can be modified 

Text box (displaying the text Form1)
which can be modified 

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.5 | Text box control for modifying a property in the Visual Studio IDE.
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2.2 Overview of the Visual Studio 2008 
IDE (Cont.)IDE (Cont.)

• Figure 2.6 shows a dialog in which a control’s font 
properties can be modifiedproperties can be modified.

OK button

Cancel button

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.6 | Dialog for modifying a control’s font properties in the Visual Studio IDE. 
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2.3 Menu Bar and Toolbar

• Many commands are contained in menus (Fig. 2.7).
• The set of menus displayed depends on what you are 

currently doing in the IDE.

Fig. 2.7 | Visual Studio menu bar.
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2.3 Menu Bar and Toolbar (Cont.)
 Menu Description 

 File Commands for opening, closing, adding and saving projects, as well as p g g g g p j
printing project data and exiting Visual Studio. 

 Edit Commands for editing programs, such as cut, copy, paste, undo, redo, 
delete, find and select. 

View Commands for displaying IDE windows and for adding toolbars View Commands for displaying IDE windows and for adding toolbars.

 Project Commands for managing projects and their files. 

 Build Commands for compiling Visual Basic programs. 

Debug Commands for debugging and running programs Debug Commands for debugging and running programs.

 Data Commands for interacting with databases. 

 Format Commands for arranging and modifying a Form’s controls. 

T l C d f i dditi l IDE t l d ti Tools Commands for accessing additional IDE tools and options.

 Window Commands for hiding, opening, closing and displaying IDE windows. 

 Help Commands for accessing the IDE’s help features. 

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.8 | Summary of Visual Studio 2008 IDE menus. 
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2.3 Menu Bar and Toolbar (Cont.)

Comment out the

• You can access common commands from the toolbar icons
(Fig. 2.9).

New
Project 

Add New Item

Save 

Cut 

Paste 

Comment out the
selected lines 

Undo Navigate
Backward 

UncommentOpen File Save All Copy Find
Uncomment
the selected
lines 

Redo Navigate
Forward 

Start Stop Step Over 
Solution
Explorer

Object
Browser Error List

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.9 | Standard Visual Studio toolbar. 

ImmediateToolboxProperties
Window

Step Out Step Into Break All 
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2.3 Menu Bar and Toolbar (Cont.)

• Select View > Toolbars (Fig. 2.10).
• Each toolbar you select is displayed at the top of the Visual• Each toolbar you select is displayed at the top of the Visual 

Studio window.
Additional
Toolbars appear
here

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.10 | Adding the Build toolbar to the IDE. 
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2.3 Menu Bar and Toolbar (Cont.)

• Some icons contain a down arrow that you can click to 
display related or commands (Fig 2 11)display related or commands (Fig. 2.11). 

Toolbar

Down arrow indicates
additional commands

Fig. 2.11 | IDE toolbar icon showing additional commands. 
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2.3 Menu Bar and Toolbar (Cont.)

• Positioning the mouse pointer over an icon highlights 
it and after a brief pause displays a description calledit and, after a brief pause, displays a description called 
a tool tip (Fig. 2.12). 

Tool tip displayed when
the mouse pointer rests

on an icon for a fewon an icon for a few
seconds

Fig 2 12 | Tool tip demonstrationFig. 2.12 | Tool tip demonstration. 
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2.4 Navigating the Visual Studio IDE

• The IDE provides windows for accessing project files 
and customizing controls (Fig 2 13)and customizing controls (Fig. 2.13). 

Properties
window

Object
Browser

Solution
Explorer

Toolbox

Fig. 2.13 | Toolbar icons for four Visual Studio windows. 
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2.4 Navigating the Visual Studio IDE 
(Cont.)(Cont.)

• Visual Studio provides a space-saving feature called 
auto hideauto-hide.

– When auto-hide is enabled, a tab appears along the edge of the 
IDE window (Fig. 2.14).( g )

I f hidd i dIcon for hidden window
(auto-hide enabled)

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.14 | Auto-hide feature demonstration. 
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2.4 Navigating the Visual Studio IDE 
(Cont.)(Cont.)

– Placing the mouse pointer over one of these icons displays that 
window (Fig. 2.15). ( g )

Horizontal orientation for pin icon
when auto-hide is enabled

Toolbox
title bar

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.15 | Displaying a hidden window when auto-hide is enabled. 
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2.4 Navigating the Visual Studio IDE 
(Cont.)(Cont.)

– To “pin down” a window, click its pin icon.
Wh t hid i bl d th i i i h i t l– When auto-hide is enabled, the pin icon is horizontal.

– When a window is “pinned down,” the pin is vertical (Fig. 2.16).  

Vertical orientation for pinVertical orientation for pin 
icon

when window is pinned 
down

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.16 | Disabling auto-hide (“pinning down” a window). 
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2.4 Navigating the Visual Studio IDE 
(Cont.)
2.4.1 Solution Explorer

(Cont.)

• The Solution Explorer (Fig. 2.17) provides 
access to all of the solution’s files.

• The solution’s startup project is the one that runs 
when you select Debug > Start Debugging.  

Toolbar

Startup project

Show All Files icon

p p j

Fi 2 17 S l ti  E l ith j t

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.17 | Solution Explorer with an open project. 
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2.4 Navigating the Visual Studio IDE 
(Cont.)

• Clicking the Solution Explorer’s Show All Files
icon displays all the files in the solution (Fig 2 18)

(Cont.)

icon displays all the files in the solution (Fig. 2.18). 

Pl bPlus box
Minus box 

Fig. 2.18 | Solution Explorer showing plus boxes and minus boxes for expanding and 

 2009 Pearson Education, Inc.  All rights reserved.

g | p g p p g
collapsing the tree to reveal or hide project files.
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2.4 Navigating the Visual Studio IDE 
(Cont.)

• The plus and minus boxes can be clicked to expand and 
collapse the project tree

(Cont.)

collapse the project tree.
– Click the plus box to the left of My Project (Fig. 2.19). 

Minus box indicates
that the file or folder

is expanded (changed 
from plus box) 

Fig 2 19 | Solution Explorer expanding the My Project file after clicking its plus box

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.19 | Solution Explorer expanding the My Project file after clicking its plus box. 
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2.4 Navigating the Visual Studio IDE 
(Cont.)

– Click the minus box to collapse the tree from its expanded state 
(Fig. 2.20). 

(Cont.)

( g )

Plus boxes indicate
that the file or folder

is collapsed (changedis collapsed (changed
from minus box)

Fi 2 20 | S l ti E l h i ll d d ft ll i b li k d

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.20 | Solution Explorer showing collapsed nodes after all minus boxes are clicked.
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2.4 Navigating the Visual Studio IDE (Cont.)
2.4.2 Toolbox

Controls

Group names

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.21 | Toolbox window displaying controls for the Common Controls group.
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2.4 Navigating the Visual Studio IDE (Cont.)
2.4.3 Properties Window

• Select View > Properties Window S op s do
(Fig. 2.22).

– The Properties window allows you to modify a control’s 
properties visually, without writing code.

– At the top of the Properties window is the component 
selection drop-down list.selection drop down list.

 2009 Pearson Education, Inc.  All rights reserved.
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2.4 Navigating the Visual Studio IDE (Cont.)

Component selection

ToolbarCategorized icon

Alphabetic icon

Scrollbox

Properties

Scrollbox

Property values

Fi 2 22 P ti i d

Description

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.22 | Properties window.
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2.5 Using Help

• Some Help menu commands are summarized in Fig. 2.23.

 Command Description 

 How Do I? Contains links to relevant topics, including how to upgrade programs 
and learn more about Web services, architecture and design, files and 
I/O, data, debugging and more. 

 Search Finds help articles based on search keywords. 

 Index Displays an alphabetized list of topics you can browse. 

 Contents Displays a categorized table of contents in which help articles are 
organized by topic. 

Fig. 2.23 | Help menu commands. 
 

 2009 Pearson Education, Inc.  All rights reserved.
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2.5 Using Help (Cont.)
• To use context-sensitive help, click an item, then press 

the F1 key (Fig. 2.24).

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.24 | Using context-sensitive help.
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2.5 Using Help (Cont.)

• The Help options can be set by selecting Tools > Options
• Make sure that Show all settings is checked (Fig. 2.25).e su e S o a se gs s c ec ed ( g. . 5).
• Select Help, then set the Show Help using:

drop-down list to External Help.
Show Help using drop down list

Help options selected
Show Help using drop-down list

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.25 | Options dialog displaying Help settings.
Show all settings CheckBox



352.6 Using Visual Programming to Create a 
Simple Program... (Cont.) p g ( )

• Figure 2 26 shows the result of a program as it• Figure 2.26 shows the result of a program as it 
executes. 

Label control

PictureBox controlPictureBox control

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.26 | Simple program executing.



362.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Select File > New Project (Fig. 2.27).
• From the template options select Windows Forms • From the template options, select Windows Forms 

Application.
– Name the project ASimpleProgram and click OK.

Template 
types

Type the project name

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.27 | New Project dialog.



372.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Select File > Save All to display the Save • Select File > Save All to display the Save 
Project dialog (Fig. 2.28). 

Fig. 2.28 | Save Project dialog.
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382.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

– To set the project location click the Browse  button– To set the project location, click the Browse… button 
(Fig. 2.29). 

Selected project location

Fi 2 29 | S tti th j t l ti i th P j t L ti  di l

Click to set project
location

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.29 | Setting the project location in the Project Location dialog.



392.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• When you first begin working in the IDE, it is in Design Mode.When you first begin working in the IDE, it is in Design Mode.
– The text in the Form’s title bar is determined by the Form’s 
Text property (Fig. 2.30).

Name and type of object

Property valueSelected property

Property description

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.30 | Setting the Form’s Text property in the Properties window.



402.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

– Press the Enter key when finished (Fig 2 31)– Press the Enter key when finished (Fig. 2.31).
– Click and drag sizing handles to resize the Form.

Title bar

Fig. 2.31 | Form with enabled sizing handles.

Enabled sizing 
handles

 2009 Pearson Education, Inc.  All rights reserved.



412.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

– Click and drag one of the Form’s enabled sizing handles to– Click and drag one of the Form s enabled sizing handles to 
make the Form larger (Fig. 2.32). 

Fi 2 32 | R i d F

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.32 | Resized Form.



422.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Clicking BackColor in the Properties window causes a 
down-arrow button to appear (Fig. 2.33).pp ( g )

• The arrow displays tabs for Custom, Web and System. 
Click the Custom tab to display the palette. 

Current 
color

Down-arrow 
button

Light 
blue

Custom palette

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.33 | Changing the Form’s BackColor property.



432.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Once you select a color the palette closes and the• Once you select a color, the palette closes and the 
Form’s background color changes (Fig. 2.34).

New background color

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.34 | Form with new BackColor property applied.



442.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Select View > Toolbox to display the set of controls• Select View > Toolbox to display the set of controls.
• Double click the Label control in the Toolbox

(Fig 2 35)(Fig. 2.35). 
Label control

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.35 | Adding a Label to the Form.



452.6 Using Visual Programming to Create a 
Simple Program… (Cont.)p g ( )

• Set the Label’s Text property to Welcome to
Visual Basic!.Visual Basic!.

• Set the AutoSize property to False (Fig. 2.36)
so that you can resize the Label on your own. y y

AutoSize property

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.36 | Changing the Label’s AutoSize property to False.



462.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Resize the Label so that the text fits.
C t th Label t l h i t ll b l ti

p g ( )

• Center the Label control horizontally by selecting 
Format > Center In Form
> Horizontally (Fig 2 37)> Horizontally (Fig. 2.37). 

Sizing 
handles

Label centered with 
updated Text
property

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.37 | GUI after the Form and Label have been customized.



472.6 Using Visual Programming to Create a 
Simple Program that Displays Text and an 

• Select the Font property which causes an ellipsis

p g p y
Image (Cont.)

• Select the Font property, which causes an ellipsis
button to appear next to the value (Fig. 2.38).

Ellipsis button

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.38 | Properties window displaying the Label’s properties. 



482.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• When the ellipsis button is clicked, the Font dialog
(Fig 2 39) is displayed

p g ( )

(Fig. 2.39) is displayed.
– Under Font, select Segoe UI.
– Under Size, select 24 points and click OK. 

F t lFont sample

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.39 | Font dialog for selecting fonts, styles and sizes.



492.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Select the TextAlign property (Fig. 2.40).

p g ( )

– Set the TextAlign property to MiddleCenter to have the 
text to appear centered in the Label. 

Text alignment 
options

Middle-center 
alignment option

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.40 | Centering the Label’s text.



502.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• The PictureBox control displays images.
i

p g ( )

• Locate the PictureBox in the Toolbox and double 
click it to add it to the Form (Fig. 2.41). 

Updated
Label

PictureBox

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.41 | Inserting and aligning a PictureBox.



512.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Locate the Image property (Fig. 2.42).

p g ( )

• No picture has been assigned, so the value of the 
Image property displays (none). 

Image property value
(no image selected)

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.42 | Image property of the PictureBox. 



522.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Click the ellipsis button to display the Select 

p g ( )

p p y
Resource dialog (Fig. 2.43). 

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.43 | Select Resource dialog to select an image for the PictureBox.



532.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Click the Import…button.

p g ( )

• Locate bug.png, select it and click OK
• The resource named bug represents bug.png

(Fig. 2.44).

Image file name

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.44 | Select Resource dialog displaying a preview of selected image. 



542.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Click OK to place the image in your program. Supported 
image formats include PNG GIF JPEG and BMP

p g ( )

image formats include PNG, GIF, JPEG and BMP.
• To size the image to the PictureBox, change the 
SizeMode property to StretchImage (Fig. 2.45). 

SizeMode

property set to 
StretchImage

SizeMode

property

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.45 | Scaling an image to the size of the PictureBox.



552.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

R i h Pi t B ki i l (Fi 2 46)

p g ( )

• Resize the PictureBox, making it larger (Fig. 2.46).
• Select File > Save All to save the entire solution. 

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.46 | PictureBox displaying an image.



562.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• Select Debug > Start Debugging to execute the 
program (Fig 2 47)

p g ( )

program (Fig. 2.47). 
Debug menu

 2009 Pearson Education, Inc.  All rights reserved.
Fig. 2.47 | Debugging a solution.



572.6 Using Visual Programming to Create a 
Simple Program… (Cont.)

• In run mode, the program is executing, and you can interact 
with only a few of the IDE features (Fig. 2.48).

p g ( )

IDE displays text Running which
signifies that the program is executing

Form

 2009 Pearson Education, Inc.  All rights reserved.

Fig. 2.48 | IDE in run mode, with the running program in the foreground.
Running program


