3.3 Ideas and drum notation

If you are starting from this section of the project, you should open the example score called Project 3 and make the 3 Ideas and drum notation version into the Current version, by choosing File › Versions › Edit Versions, selecting this version in the list, and clicking Make current.

In this chapter we’ll explore one of Sibelius's most powerful creative tools, the Ideas window, with which you can save snippets of music of any length, called ideas, for later retrieval and re-use. You can provide tags (or keywords) for each idea, making it easy to find them later on.

Not only does Sibelius allow you to capture your own creativity so quickly, but it also comes with more than 1500 built-in ideas covering a variety of musical genres and many different instruments, so if you're stuck for inspiration or looking for something stylish to kickstart your creative process, you'll find something suitable in seconds.

Having already looked at writing for keyboard and guitar, we'll also learn how to create drum notation in this chapter. Using the Ideas window to help with writing for percussion can save you a lot of time, as we'll see.

Add a drum staff to the score
The score we've been working on so far has no drum staff in it, so let's add one:

- Choose Create › Instruments, or hit the shortcut I
- From the Choose from list, select Common Instruments
- Choose the Percussion and Drums family and then select Drum Set (Rock)
- Click Add to Score, and Drum Set (Rock) will appear in the Staves in score list, click on it there to select it
- Use the Down button to re-order Drum Set (Rock) so that it appears between 5-string Bass Guitar and Synthesizer (a)
- Click OK to return to the score.

Now you should see a percussion staff added to your score, ready for you to write a drum part.

Auditioning drum ideas
Show the Ideas window, if it's not already shown, by choosing Window › Ideas (shortcut Ctrl+Alt+l or ~#f). The Ideas window has two views, compact and detailed. By default it opens in compact view, which looks like this:
Project 3

Try switching between Library, Score and All. When the Library button is switched on, you have access to the more than 2000 built-in ideas. Try scrolling up and down the list.

Each idea shows a small preview of the music or other objects contained within it; normally you will see two or three bars of one staff (although ideas can contain any number of bars or instruments). Important tags are shown in the four corners around the notation preview: at the top left, the idea's name; at the top right the letter L appears if the idea is located in the library rather than the current score; at the bottom left, the time signature of the idea; and at the bottom right, the tempo of the idea.

To check how an idea sounds, simply click and hold the mouse button on it: the idea will play in a loop repeatedly until you release the mouse button.

You can search for ideas that correspond to a particular style or genre by typing different tags at the top of the window. This way you can quickly narrow the list of ideas down to ones that might be suitable.

Try typing a few tags to get an inkling of just how many different ideas in a variety of styles and genres are included with Sibelius: motown, funk, happy, melody, slow. Now, let's use some ideas suitable for the score we've just created: clear any tags you have typed from the top of the window and click on the Score button. Near the top of the list you will see Urban Funky Drum Loop 1.

Pasting an idea

So let's use this idea for ourselves. First, select Urban Funky Drum Loop 1 in the Ideas window; notice how a border appears around it to show that it's selected. Now copy it to the clipboard, either by typing Ctrl+C or #C, or by clicking the Copy button at the bottom of the window. (You can also right-click (Windows) or Control-click (Mac) and choose Copy from the context menu.)

Pasting an idea into a score is just like any other kind of pasting: either select the place in the score where you want the idea to appear, then choose Edit > Paste (shortcut Ctrl+V or #V); or make sure you have nothing selected, then choose Edit > Paste, and click in the score where you want the idea to go. You could also click the Paste button at the bottom of the Ideas window. Select the first full bar of the Drum Set staff in the score, and type Ctrl+V or #V to paste it in.

You should see that the idea we just pasted in matches the first four bars of drum notation after the pick-up (upbeat) on your printout.

You can add the next bar of music by pasting the Urban Funky Drums 2 idea into bar 5 in the same manner.

Inputting drum notation

When inputting into percussion staves, you can use any of the note input methods we've already learned, but for drum notation – which uses different types of noteheads – it is much quicker to use step-time or Flexi-time input.

If you have a MIDI keyboard connected to your computer, you can simply play the pitch that corresponds to the line or space on the staff (as if it's a treble clef staff) and Sibelius automatically chooses the correct notehead. (If you don't have a MIDI keyboard connected, input the notes using alphanumeric input and see Changing Noteheads below to change them manually.)

Let's input the drum pattern in bar 6:
3.3 Ideas and drum notation

- Select the bar rest in bar 6 and hit N to begin note input
- Hit 3 on the numeric keypad to choose an eighth note (quaver)
- On your MIDI keyboard, play the G above the staff; this corresponds to a closed hi-hat
- Notice how Sibelius changes the notehead to a cross:

\[ \text{Input another three eighth note hi-hats} \]

- Hit 2 on the numeric keypad to choose a sixteenth note (semiquaver)
- Play G on your MIDI keyboard twice to input two sixteenth note hi-hats.

In this way, continue to input the hi-hat notes for the rest of the bar; to add the circle symbol to the open hi-hat note, simply hit F10 to choose the fourth Keypad layout, then hit . (on the numeric keypad), which corresponds to the Harmonic/Open button. You can hit . again to remove the circle symbol if you need to; make sure you hit F7 to return to the first Keypad layout to continue inputting notes.

Sibelius can write up to four independent voices, or lines of notes and chords, on a single staff. The voices are color-coded: voice 1 (which we’ve used so far) is dark blue, voice 2 is green, voice 3 is orange, and voice 4 is pink; you’ll rarely need to use more than two voices at a time.

In order to add the bass drum and snare pattern so that their stems always point down while the hi-hat note stems point up, we’ll be using voice two:

- First, hit Esc to make sure you have nothing selected
- Now type Alt+2 or ~2 to switch voices, or click 2 on the row of buttons at the bottom of the Keypad
- Choose a sixteenth note by hitting 2 on the numeric keypad
- The mouse pointer turns green, to show that it is “carrying” an object which will be inputted in voice 2
- Now click the mouse pointer near the start of the sixth bar, pointing at the F space, the bottom space on the staff:

\[ \text{Finish adding the bass and snare drum pattern to bar 6 using your MIDI keyboard as before.} \]

For lots more detail about voices, \(2.36 \text{ Voices}\) in Reference.

Changing noteheads

If you enter notes into a percussion staff using alphabetic input, Sibelius doesn’t change the noteheads automatically for you, so let’s learn how to do that manually by inputting the same pattern in bar 7, this time using the computer keyboard:

- Select the bar rest in bar 7 and hit N to begin note input
- Hit 3 on the numeric keypad to choose an eighth note (quaver)
Project 3

- Type G on your computer keyboard; make sure it goes above the staff
- Input another three eighth notes by hitting R
- Hit 2 on the numeric keypad to choose a sixteenth note (semiquaver)
- Type G on your computer keyboard twice to input two sixteenth note

Now that you’ve added the hi-hat notes, input the bass drum and snare pattern in voice 2:

![MIDI notation]

Sibelius allows you to filter a selection, which means that you can select a set of objects with particular characteristics. Let’s try this now:

- Select bar 7 so that it is surrounded by a blue box
- Choose Edit › Filter › Voices › Voice 1 (shortcut Ctrl+Shift+Alt+1 or ⌘ 1)
- Sibelius makes a multiple selection of only the notes in voice 1, i.e. the hi-hat notes.

Now any edits you make will only apply to the selected notes in voice 1. So let’s change the notehead:

- Change the notehead by typing Shift+Alt+1 or ⌘ 1
- All the notes change to display a cross notehead:

![MIDI notation]

Alternatively you can choose the notehead from the menu in the Notes panel of the Properties window. If you can’t see the Properties window, you can switch it on by choosing Window › Properties (shortcut Ctrl+Alt+P or ⌘ P).

To learn more about noteheads, § 2.25 Noteheads in Reference.

Capturing an idea

Now let’s try making a new idea. The process of putting an idea into the Ideas window is called capturing an idea:

- select bar 7 so that it is surrounded by a blue box
- choose Edit › Capture Idea (shortcut Shift-I), or click on the Capture Idea button (_axes ) at the bottom of the Ideas window.

The music you selected immediately appears at the top of the list in the Ideas window, so you can re-use it later.

Editing an idea

You can edit both the music and the tags of ideas.

To try out editing tags, select the idea you just captured in the Ideas window, then click the Edit Idea Info button ( Axes ) at the bottom of the window (or right-click (Windows) or Control-click...
3.3 Ideas and drum notation

(Mac) on an idea in the list and choose Edit Idea Info from the context menu. A simple dialog appears:

- Give your idea a new Name here; type Urbane Funky Drums 1
- You can also type a few tags into the Tags box: there's no limit on what you can type, so use as many words as you can think of that will help you to find your idea again later on
- Click Color to show a color picker and choose a new background color for your idea. Again, you can use color to categorize your ideas and to make it easier to find them again later on.
- When you're satisfied with your choices, click OK to close the Edit Idea Info dialog.

To edit the music in an idea, select your idea again in the Ideas window, then click the Edit Idea button ( ✓ ) at the bottom of the window (or choose Edit Idea from the context menu). A new document window will appear, as if you had opened another score. You can edit it just like any other score, e.g. adding or deleting notes and bars, adding text, lines and other markings, and so on. When you have finished editing your idea, simply save it by choosing File → Save (shortcut Ctrl+S or ⌘S), then close the window by choosing File → Close (shortcut Ctrl+W or ⌘W) to return to your original score.

If you want to discard any unsaved changes in your idea, simply choose File → Close, then click No when asked if you want to save your changes.

We've barely scratched the surface of what you can do with ideas. So don't forget — 5.11 Ideas in Reference.

Repeat bars

Often, drum and other percussion parts are made up of repeated patterns of one or two bars' length. Rather than copying the same bar out numerous times, arrangers often add a repeat bar symbol. This tells the performer to play the exactly same pattern as the previous bar. Sibelius understands this and plays back repeat bars just as a real performer would.

Let's add a tambourine part to the score to learn how this works:

- Choose Create → Instruments, or hit the shortcut I
- From the Choose from list, select Common Instruments
- Choose the Percussion and Drums family and then select Tambourine
- Click Add to Score
- Select Tambourine from the Staves in score list and use the Down button to re-order it so that it appears between Drum Set (Rock) and Synthesizer (a)
- Click OK to return to the score.

Now you should see a percussion staff added to your score, ready for you to write a drum part. Next, click the Score button in the Ideas window and find the Urbane Tambourine 1 idea from the list. Copy and paste this idea into bar 9.

To add a repeat bar symbol, select bar 10 of the tambourine staff and hit F11 to view the fifth Keypad layout. Now hit 1 (on the numeric keypad) to add a single repeat bar. Keep typing 1 until you reach bar 16.
Project 3

Notice that you can also add 2- and 4-bar repeats from the fifth Keypad layout. Sibelius will playback all these different kinds of repeats.

For more about repeat bars, see 2.27 Repeat bars in Reference.

Finish the percussion parts

Input the remainder of the music on the Drum Set and Tambourine parts, referring to the printout we made earlier. Use the Ideas window, repeat bars and multiple voices to help you finish inputting the percussion parts.